• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • Welcome to iHelpForum - the place to get help from knowledgeable techs in all areas of Tech, Home and Auto help. Consider checking out our Guides or Registering an account to post on our forums today.

Solved Gigabit Networking

Crush

I am admin, ruler of my domain
Administrator
iHF Master Craftsman
#1
Hi guys,

@DCiAdmin @Samuria - Help :)

Man Cave is having some woes. I've been fighting with this a couple days. My setup is not giving me the theoretical fully saturated link speed between devices.

The setup is:
ONT -> FiOS Quantium Gateway Router w/Switch -> Netgear DGS-1005G -> Synology DS415Play NAS, and Desktop with a BCM57788 onboard NIC

They are all interconnected with CAT6 rated cable. I've tried switching out the switch with a Netgear GS308 and get the same results.

The only thing I have not tried is connecting the NAS directly to the PC because of the fact that I'm troubleshooting over a network share.

Router is showing full link speed on one port. The other ports are standard Fast Ethernet Speeds.

Capture.PNG

Capture2.PNG

What the heck is nerfing my other ports, and if Port 4 which is what the switches have been connected to is showing Gigabit, why am I only getting 12.5 mbps approximately on a file transfer?

Surely even slightly below due to overhead, of the theoretical maximum of Gigabit networking I should be getting betters speeds right?
 

Lord Chance

iHelpForum Jester & Door Greeter
iHF Veteran
Advisor
WCG Team Member
#2
Question....What are ports 1 and 2 connected to? Check your Cables. They should really be Cat6 instead of Cat5. Yes Cat5 should carry but some of the cheaper Cat5 patch cables are just not up to the task. Your switch is unmanaged so if you plug a Gigabit capable device in it should sense it and switch accordingly. Also check your QOS settings on the router.

(Edited due to me being a blind idiot.)
Geez! I am blind. Just reread and see you are using Cat6 But it might might be reasonable to test your cables anyway.
 

Crush

I am admin, ruler of my domain
Administrator
iHF Master Craftsman
#3
1,2, and 3 are connected to jacks which terminate in another room.

4 on the router is connected to port 1 on the switch. Switch has two devices on it plus the uplink.

And yes, everything is CAT6e that I made myself.
 

Crush

I am admin, ruler of my domain
Administrator
iHF Master Craftsman
#6
Forgive me for saying Crush but I don't think you will see true Gigabit speeds from that switch because the Transmission Method is Store-and-forward and the RAM Buffer is only 128Kbytes per device. Data intensive files will keep that buffer overworked. :)
I had figured it would be something like that and am looking at upgrading the switch

I'll have a look at the router manual tonight. Appreciate the second set of eyes.
 

Crush

I am admin, ruler of my domain
Administrator
iHF Master Craftsman
#8
Hey LC.

I've set the speed manually, rebooted the router but no dice. It did not change here.

Capture1.PNG Capture2.PNG

Capture3.PNG

All that *should* matter here is the speed on port 4 which is Full Duplex Gigabit, but is the switch just not powerful enough?

I bypassed the switch completely and plugged directly into the Router, no change in connection speed but I managed to confirm it auto-negotiates at Gigabit speed

Switch Bypassed.PNG

Bypassed 2.PNG
 
Last edited:

Lord Chance

iHelpForum Jester & Door Greeter
iHF Veteran
Advisor
WCG Team Member
#9
You have port 1 and 2 terminating in other rooms? What is connected? It is possible you have bad cable runs.
1,2, and 3 are connected to jacks which terminate in another room.

4 on the router is connected to port 1 on the switch. Switch has two devices on it plus the uplink.
1,2 and 3 are coming off the router. Port 3 and 4 are showing good so the switch isn't the bottleneck. or am I reading this backward. I think not so lets not fret over the switch at this time. One problem at a time Mate or you will have grey hair like me. Plug a short patch cord into port 1 and 2 with a known good Gigabit adapter. ;)
 

Crush

I am admin, ruler of my domain
Administrator
iHF Master Craftsman
#10
You have port 1 and 2 terminating in other rooms? What is connected? It is possible you have bad cable runs.
1,2, and 3 terminate in other rooms, yeah. But they have no bearing on the connection between the NAS and the router.

I'm taking the first three ports in my router and plugging them into jacks on one wall. They terminate at another wall in another room. Xbox and a Chromecast are connected.

The switch which is plugged into Port 4 on my Modem/Router/Switch combination device has the NAS plugged into it. Like I said before I also plugged directly into port 3 on the Modem/Router/Switch combination device but got the same results.
 

Lord Chance

iHelpForum Jester & Door Greeter
iHF Veteran
Advisor
WCG Team Member
#11
I think I begin to see Crush. While you will never get anywhere near Gigabit speeds you should be able to improve throughput. This brings me back to QOS settings if your router allows it. Most consumer routers limit these settings unfortunately. In this case I usually disable the feature.
 

Lord Chance

iHelpForum Jester & Door Greeter
iHF Veteran
Advisor
WCG Team Member
#13
Because of the Router you believe? Even though it's seemingly set to Full Duplex Gigabit?
Not just the router my friend. Limitations due to read/write speed of the drives, network congestion, buss speeds, processor loads. I do see room for improvement with some tweaks to your router but with those tweaks come other headaches if not done properly. Truly consumer hardware is limited. Have a looksee at the QOS settings of your router. It may be worth disabling but I doubt it will help that much. While I have installed a lot of network hardware I am no expert. I hope you will forgive me. :)
 

Crush

I am admin, ruler of my domain
Administrator
iHF Master Craftsman
#15
LC.

Here is something interesting:

Untitled.png

Despite the fact that it appears my NIC supports Gigabit speeds there is no explicit option for it in Speed & Duplex. When I set this the other night I just left it on Auto
 

Lord Chance

iHelpForum Jester & Door Greeter
iHF Veteran
Advisor
WCG Team Member
#16
LC.

Here is something interesting:

View attachment 4915

Despite the fact that it appears my NIC supports Gigabit speeds there is no explicit option for it in Speed & Duplex. When I set this the other night I just left it on Auto
That is interesting. You made me go and look at my NIC. It has always been my practice to use Auto but the option was there to force Speeds. I stay with Auto to assure reliability.

2016-09-29_191436.png
 

Samuria

Network Specalist
Moderator
#17
A few thoughts the port that is getting full speed if you plug the other devices into that cable do they get full speed?
You say you made the cables did you keep the right pairs if you mix pairs it will work but suffer speed http://www.solwise.co.uk/downloads/files/cat5wiring.pdf
If you copying between 2 devices the mtu needs to be the same on both.
Full duplex means send and receive at the same time often this isnt needed if you just copying a file its 1 way only so half duplex can be better
 

Crush

I am admin, ruler of my domain
Administrator
iHF Master Craftsman
#18
So, I have not heard back from my support ticket with Synology yet other than to ask me to do things I've already done :rolleyes:

I tried disabling Write Caching on the RAID volume, but that didn't improve anything